Milliman integration reporting slowness processing orders

Incident Report for Agenium

Resolved

Processing times have returned to normal.
Posted Jul 26, 2023 - 17:58 CDT

Update

An update from Milliman:

Dear Clients & Third Party Contacts,

This is being sent to our primary business and IT distribution contacts. Please forward this email to your users as you see fit.

We continue to work through the order processing and website slowness. Our team is working to return to normal operations.

We will send out an update when things return to normal. We apologize for the inconvenience and thank you for your patience.
Posted Jul 26, 2023 - 13:45 CDT

Identified

From Milliman:

Dear Clients & Third Party Contacts,

This is being sent to our primary business and IT distribution contacts. Please forward this email to your users as you see fit.

We are currently experiencing order processing slowness due to a connectivity issue. Our team is working to return to normal operations.

We will send out an update when things return to normal. We apologize for the inconvenience and thank you for your patience.
Posted Jul 26, 2023 - 12:05 CDT
This incident affected: 3rd Party Integrations.