Docusign

Incident Report for Agenium

Resolved

This incident has been resolved.
Posted Sep 12, 2023 - 15:30 CDT

Monitoring

An update from Docusign: "The incident has been mitigated and we are monitoring the results."
Posted Sep 12, 2023 - 15:21 CDT

Investigating

Docusign is reporting that approximately 20% of their users are having issues with signing and they are investigating the issue. We will update our status page once we know more.
Posted Sep 12, 2023 - 14:49 CDT
This incident affected: 3rd Party Integrations.